CVE-2025-48888

Source
https://cve.org/CVERecord?id=CVE-2025-48888
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48888.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2025-48888
Aliases
Downstream
Published
2025-06-04T19:15:55Z
Modified
2026-10-24T10:30:40Z
Severity
  • 5.5 (Medium) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P CVSS Calculator
Summary
Deno run with --allow-read and --deny-read flags results in allowed
Details

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, deno run --allow-read --deny-read main.ts results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as --allow-* --deny-*. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.

Database specific
{
    "cna_assigner":  "GitHub_M",
    "cwe_ids":  [
        "CWE-863"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48888.json"
}
References

Affected packages

Git / github.com/denoland/deno

Affected ranges

Type
GIT
Repo
https://github.com/denoland/deno
Events
Database specific
Show details
{
    "extracted_events":  [
        {
            "cpe":  "cpe:2.3:a:deno:deno:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "1.41.3"
                },
                {
                    "fixed":  "2.1.13"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:deno:deno:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.2.0"
                },
                {
                    "fixed":  "2.2.13"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:deno:deno:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2.3.0"
                },
                {
                    "fixed":  "2.3.2"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "range":  [
                {
                    "fixed":  "2f0fae9d9071dcaf0a689bc7097584b1b9ebc8db"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        },
        {
            "range":  [
                {
                    "fixed":  "9d665572d3cd39f997e29e6daac7c1102fc5c04f"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        },
        {
            "range":  [
                {
                    "fixed":  "ef315b56c26c9ef5f25284a5100d2ed525a148cf"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

v2.*
v2.2.0
v2.2.1
v2.2.10
v2.2.11
v2.2.12
v2.2.2
v2.2.3
v2.2.4
v2.2.5
v2.2.6
v2.2.7
v2.2.8
v2.2.9
v2.3.0
v2.3.1

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48888.json"