Frappe HRMS 14.x before 14.38.2, 15.x before 15.64.0, and 16.x before 16.18.0 contains a SQL injection vulnerability in some endpoints caused by missing input validation. Any authenticated attacker, including a low-privilege account, can send specially crafted requests to these endpoints to extract sensitive information from the database.
{
"cna_assigner": "VulnCheck",
"cwe_ids": [
"CWE-89"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/111xxx/CVE-2026-111389.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "14.0.0"
},
{
"fixed": "14.38.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "15.0.0"
},
{
"fixed": "15.64.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "16.0.0"
},
{
"fixed": "16.18.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}