Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.
{
"cna_assigner": "GitHub_M",
"cwe_ids": [
"CWE-79"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/23xxx/CVE-2026-23891.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.30.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "0.31.0"
},
{
"fixed": "0.31.1"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v0.30.5",
"range": [
{
"fixed": "ed4d23c283cb03d3423493aeb5a7860bc8f5bfa3"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "v0.31.1",
"range": [
{
"fixed": "0a9443ed804ee6274fab904878bc0103af1c0f69"
}
],
"source": "REFERENCES_TAG"
}
]
}