CVE-2026-27166

Source
https://cve.org/CVERecord?id=CVE-2026-27166
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27166.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-27166
Aliases
Published
2026-03-19T20:29:22Z
Modified
2026-10-28T02:30:45Z
Severity
  • 4.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N CVSS Calculator
Summary
Discourse vulnerable to HTML injection via prohibited iframe URLs
Details

Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.

Database specific
{
    "cna_assigner": "GitHub_M",
    "cwe_ids": [
        "CWE-80"
    ],
    "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27166.json"
}
References

Affected packages

Git / github.com/discourse/discourse

Affected ranges

Type
GIT
Repo
https://github.com/discourse/discourse
Events
Database specific
Show details
{
    "extracted_events": [
        {
            "cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "2026.3.0"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "2026.1.0"
                },
                {
                    "fixed": "2026.1.2"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "2026.2.0"
                },
                {
                    "fixed": "2026.2.1"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "cpe": "cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest:*:*:*",
            "range": [
                {
                    "introduced": "2026.3.0"
                },
                {
                    "last_affected": "2026.3.0"
                }
            ],
            "source": "CPE_STRING"
        },
        {
            "range": [
                {
                    "fixed": "c4762a4fac2f61f52f325396b11d3aeb955ea925"
                }
            ],
            "source": "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

2026.*
2026.3.0
Other
esr
stable
v2026.*
v2026.1.0
v2026.1.0-latest
v2026.1.1
v2026.2.0
v2026.2.0-latest

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27166.json"