CVE-2026-31805

Source
https://cve.org/CVERecord?id=CVE-2026-31805
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-31805.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-31805
Aliases
Published
2026-03-20T03:07:14Z
Modified
2026-10-21T02:30:35Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Discourse has a poll authorization bypass via post_id array parameter
Details

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, an authorization bypass in the poll plugin allowed authenticated users to vote on, remove votes from, or toggle the open/closed status of polls they did not have access to. By passing post_id as an array (e.g. post_id[]=&post_id[]=), the authorization check resolves to the accessible post while the poll lookup resolves to a different post's poll. This affects the vote, remove_vote, and toggle_status endpoints in DiscoursePoll::PollsController. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch.

Database specific
{
    "cna_assigner":  "GitHub_M",
    "cwe_ids":  [
        "CWE-20",
        "CWE-863"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/31xxx/CVE-2026-31805.json"
}
References

Affected packages

Git / github.com/discourse/discourse

Affected ranges

Type
GIT
Repo
https://github.com/discourse/discourse
Events
Database specific
Show details
{
    "extracted_events":  [
        {
            "cpe":  "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2026.1.0"
                },
                {
                    "fixed":  "2026.1.2"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "2026.2.0"
                },
                {
                    "fixed":  "2026.2.1"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:discourse:discourse:2026.3.0:*:*:*:latest:*:*:*",
            "range":  [
                {
                    "introduced":  "2026.3.0"
                },
                {
                    "last_affected":  "2026.3.0"
                }
            ],
            "source":  "CPE_STRING"
        },
        {
            "range":  [
                {
                    "fixed":  "1a6b3cdd8939053f485a60a6ea004a40878392c4"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

2026.*
2026.3.0
= 2026.*
= 2026.3.0-latest.1
Other
esr
stable
v2026.*
v2026.1.0
v2026.1.0-latest
v2026.1.1
v2026.2.0
v2026.2.0-latest
v2026.3.0-latest

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-31805.json"