Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice.
This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0.
Users are recommended to upgrade to version 1.12.0, which fixes the issue.
{
"cna_assigner": "apache",
"cwe_ids": [
"CWE-295"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32794.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "1.10.0"
},
{
"fixed": "1.12.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:apache:airflow_providers_databricks:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.10.0"
},
{
"fixed": "1.12.0"
}
],
"source": "CPE_RANGE"
}
]
}