vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.
{
"cna_assigner": "GitHub_M",
"cwe_ids": [
"CWE-770"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34756.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.1.0"
},
{
"fixed": "0.19.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "b111f8a61f100fdca08706f41f29ef3548de7380"
}
],
"source": "REFERENCES_COMMIT"
}
]
}