CVE-2026-39380

Source
https://cve.org/CVERecord?id=CVE-2026-39380
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-39380.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-39380
Aliases
  • GHSA-7hg5-68rx-xpmg
Published
2026-04-07T19:49:13Z
Modified
2026-10-28T02:31:14Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Open Source Point of Sale has Stored XSS in Stock Location (Configuration)
Details

Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.

Database specific
{
    "cna_assigner":  "GitHub_M",
    "cwe_ids":  [
        "CWE-79"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/39xxx/CVE-2026-39380.json"
}
References

Affected packages

Git / github.com/opensourcepos/opensourcepos

Affected ranges

Type
GIT
Repo
https://github.com/opensourcepos/opensourcepos
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Database specific
Show details
{
    "extracted_events":  [
        {
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "3.4.3"
                }
            ],
            "source":  "AFFECTED_FIELD",
            "strategy":  "StringRangeExpression"
        },
        {
            "cpe":  "cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "3.4.3"
                }
            ],
            "source":  "CPE_RANGE"
        }
    ]
}

Affected versions

2.*
2.3.1
2.3.2
2.3.3
2.3.4
2.4.0
3.*
3.0.0
3.0.1
3.0.2
3.1.0
3.1.1
3.2.0
3.3.0
3.3.1
3.3.2
3.3.3
3.3.4
3.3.5
3.3.6
3.3.7
3.3.8
3.3.9
3.4.0
3.4.1
3.4.2
master.*
master.3.3.5
master.3.3.6
master.3.4.0-dev
Other
unstable

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-39380.json"