Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
{
"cna_assigner": "GitHub_M",
"cwe_ids": [
"CWE-770",
"CWE-789"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42189.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:russh_project:russh:*:*:*:*:*:rust:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.60.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "6c3c80a9b6d60763d6227d60fa8310e57172a4d1"
}
],
"source": "REFERENCES_COMMIT"
},
{
"original_tag": "v0.60.1",
"range": [
{
"fixed": "5a6ca29ef2171b070433308fcf0e43785b608071"
}
],
"source": "REFERENCES_TAG"
}
]
}
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:warpgate_project:warpgate:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.23.1"
}
],
"source": "CPE_RANGE"
}
]
}