OpenClaw versions 2026.4.5 before 2026.4.20 contain an environment variable injection vulnerability allowing workspace dotenv to override MINIMAX_API_HOST. Attackers can redirect credentialed MiniMax API requests to attacker-controlled origins, exposing the MiniMax API key in Authorization headers.
{
"cna_assigner": "VulnCheck",
"cwe_ids": [
"CWE-441"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44992.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "2026.4.5"
},
{
"fixed": "2026.4.20"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "2f06696579a1ab0cb5bbbbb6a900414a6b2e3cd1"
}
],
"source": "REFERENCES_COMMIT"
}
]
}