Uncontrolled Recursion vulnerability in Apache Commons.
When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0.
Users are recommended to upgrade to version 2.15.0, which fixes the issue.
{
"cna_assigner": "apache",
"cwe_ids": [
"CWE-674"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45205.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "2.2"
},
{
"fixed": "2.15.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.2"
},
{
"fixed": "2.15.0"
}
],
"source": "CPE_RANGE"
}
]
}