CVE-2026-61813

Source
https://cve.org/CVERecord?id=CVE-2026-61813
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-61813.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-61813
Aliases
  • GHSA-2vqc-36qp-ccmw
Downstream
Published
2026-11-05T15:48:15Z
Modified
2026-11-05T21:32:26Z
Severity
  • 3.7 (Low) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
ModSecurity: Incorrect libcurl TLS hostname verification setting in HttpsClient::download
Details

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.

Database specific
{
    "cna_assigner": "GitHub_M",
    "cwe_ids": [
        "CWE-295"
    ],
    "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/61xxx/CVE-2026-61813.json"
}
References

Affected packages

Git / github.com/owasp-modsecurity/modsecurity

Affected ranges

Type
GIT
Repo
https://github.com/owasp-modsecurity/modsecurity
Events
Database specific
Show details
{
    "extracted_events": [
        {
            "range": [
                {
                    "introduced": "0"
                },
                {
                    "fixed": "2.9.15"
                }
            ],
            "source": "AFFECTED_FIELD",
            "strategy": "StringRangeExpression"
        },
        {
            "range": [
                {
                    "introduced": "3.0.0"
                },
                {
                    "fixed": "3.0.17"
                }
            ],
            "source": "AFFECTED_FIELD",
            "strategy": "StringRangeExpression"
        },
        {
            "range": [
                {
                    "fixed": "cce204806430e4848327aadeb9113e654631a0c1"
                }
            ],
            "source": "REFERENCES_COMMIT"
        },
        {
            "range": [
                {
                    "fixed": "edca70d853bfb725325137fa40d178beebc324fc"
                }
            ],
            "source": "REFERENCES_COMMIT"
        },
        {
            "original_tag": "v2.9.15",
            "range": [
                {
                    "fixed": "151074aca78a416764b12ba1221e61a17a6c714d"
                }
            ],
            "source": "REFERENCES_TAG"
        },
        {
            "original_tag": "v3.0.17",
            "range": [
                {
                    "fixed": "1925753989ccce977cdaae417b55c9726c7cf02c"
                }
            ],
            "source": "REFERENCES_TAG"
        }
    ]
}

Affected versions

v2.*
v2.7.4
v2.9.0
v2.9.0-rc1
v2.9.0-rc2
v2.9.1
v2.9.1-rc1
v2.9.10
v2.9.11
v2.9.12
v2.9.13
v2.9.14
v2.9.2
v2.9.3
v2.9.4
v2.9.5
v2.9.6
v2.9.7
v2.9.9
v3.*
v3.0.0
v3.0.1
v3.0.10
v3.0.11
v3.0.12
v3.0.13
v3.0.14
v3.0.15
v3.0.16
v3.0.2
v3.0.3
v3.0.4
v3.0.5
v3.0.6
v3.0.7
v3.0.8
v3.0.9

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-61813.json"