CVE-2026-77405

Source
https://cve.org/CVERecord?id=CVE-2026-77405
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-77405.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-77405
Aliases
Downstream
AZL (2)
CLEANSTART (3)
DEBIAN (1)
ECHO (1)
MINI (36)
ROOT (1)
UBUNTU (1)
Published
2026-09-16T14:42:08Z
Modified
2026-10-28T02:31:01Z
Severity
  • 9.4 (Critical) CVSS_V4 - CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N CVSS Calculator
Summary
RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
Details

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Database specific
{
    "cna_assigner":  "GitHub_M",
    "cwe_ids":  [
        "CWE-326"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/77xxx/CVE-2026-77405.json"
}
References

Affected packages

Git / github.com/rabbitmq/amqp091-go

Affected ranges

Type
GIT
Repo
https://github.com/rabbitmq/amqp091-go
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Fixed
Database specific
Show details
{
    "extracted_events":  [
        {
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "1.13.0"
                }
            ],
            "source":  "AFFECTED_FIELD",
            "strategy":  "StringRangeExpression"
        },
        {
            "range":  [
                {
                    "fixed":  "c9fd433ecac2e557919e51acc9d809390c402c6e"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        },
        {
            "original_tag":  "v1.13.0",
            "range":  [
                {
                    "fixed":  "d26d57e952cc61554ea9c54bd676c8f40ed0d84d"
                }
            ],
            "source":  "REFERENCES_TAG"
        }
    ]
}

Affected versions

v1.*
v1.1.0
v1.10.0
v1.11.0
v1.12.0
v1.2.0
v1.3.0
v1.3.1
v1.3.2
v1.3.3
v1.3.4
v1.4.0
v1.5.0
v1.6.0
v1.6.1
v1.6.1-rc.1
v1.6.1-rc.2
v1.7.0
v1.8.0
v1.8.1
v1.9.0

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-77405.json"