An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload.
To remediate this issue, users should upgrade to version 0.37.0 or above.
{
"cna_assigner": "AMZN",
"cwe_ids": [
"CWE-190"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/85xxx/CVE-2026-85228.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "0.13.0"
},
{
"last_affected": "0.36.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"original_tag": "v0.37.0",
"range": [
{
"fixed": "9d3fca3012bb1bdf41ad088f5b6d64ec7f34a13c"
}
],
"source": "REFERENCES_TAG"
}
]
}