A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.
{
"cna_assigner": "VulDB",
"cwe_ids": [
"CWE-189",
"CWE-190"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/86xxx/CVE-2026-86289.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "0.31.0"
},
{
"last_affected": "0.31.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "0.31.1"
},
{
"last_affected": "0.31.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "67b6a1c2d45321e0cb3c04a18073f9818de7724b"
}
],
"source": "REFERENCES_COMMIT"
},
{
"original_tag": "v0.31.2-rc1",
"range": [
{
"fixed": "67b6a1c2d45321e0cb3c04a18073f9818de7724b"
}
],
"source": "REFERENCES_TAG"
}
]
}