CVE-2026-92973

Source
https://cve.org/CVERecord?id=CVE-2026-92973
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-92973.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2026-92973
Downstream
Related
Published
2026-09-17T13:43:17Z
Modified
2026-10-28T02:31:10Z
Severity
  • 5.3 (Medium) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N CVSS Calculator
Summary
ansi2html 1.7.0a0 through 1.9.3 Cross-Site Scripting via OSC 8
Details

ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.

Database specific
{
    "cna_assigner":  "VulnCheck",
    "cwe_ids":  [
        "CWE-79"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/92xxx/CVE-2026-92973.json"
}
References

Affected packages

Git / github.com/pycontribs/ansi2html

Affected ranges

Type
GIT
Repo
https://github.com/pycontribs/ansi2html
Events
Database specific
Show details
{
    "extracted_events":  [
        {
            "range":  [
                {
                    "introduced":  "1.7.0a0"
                },
                {
                    "fixed":  "1.9.4"
                }
            ],
            "source":  "AFFECTED_FIELD",
            "strategy":  "StandardRange"
        },
        {
            "range":  [
                {
                    "fixed":  "89d1c231c60ac52005f3b21bbba551c786c554fc"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

1.*
1.7.0
1.7.0a0
1.8.0
v1.*
v1.9.0rc1
v1.9.1
v1.9.2
v1.9.3

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-92973.json"