DEBIAN-CVE-2026-111821

Source
https://security-tracker.debian.org/tracker/CVE-2026-111821
Import Source
https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-111821.json
JSON Data
https://api.osv.dev/v1/vulns/DEBIAN-CVE-2026-111821
Upstream
  • CVE-2026-111821
Published
2026-11-04T10:17:25Z
Modified
2026-11-06T14:01:41Z
Summary
[none]
Details

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable.  This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

References

Affected packages

Debian:12 / activemq

Package

Name
activemq
Purl
pkg:deb/debian/activemq?arch=source&distro=bookworm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

5.*
5.17.2+dfsg-2
5.17.2+dfsg-2+deb12u1
5.17.6+dfsg-1
5.17.6+dfsg-2

Ecosystem specific

{
    "urgency": "not yet assigned"
}

Database specific

source
"https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-111821.json"

Debian:13 / activemq

Package

Name
activemq
Purl
pkg:deb/debian/activemq?arch=source&distro=trixie

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected

Affected versions

5.*
5.17.6+dfsg-2

Ecosystem specific

{
    "urgency": "not yet assigned"
}

Database specific

source
"https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-111821.json"