DEBIAN-CVE-2026-77078

Source
https://security-tracker.debian.org/tracker/CVE-2026-77078
Import Source
https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-77078.json
JSON Data
https://api.osv.dev/v1/vulns/DEBIAN-CVE-2026-77078
Upstream
Published
2026-08-28T22:16:53Z
Modified
2026-11-02T18:00:46Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.

References

Affected packages

Debian:14 / node-multer

Package

Name
node-multer
Purl
pkg:deb/debian/node-multer?arch=source&distro=forky

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
2.4.0+~cs3.2.0-1

Affected versions

2.*
2.2.0+~cs3.1.0-1
2.2.0+~cs3.1.0-2
2.2.0+~cs3.2.0-1

Ecosystem specific

{
    "urgency": "not yet assigned"
}

Database specific

source
"https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-77078.json"