DLA-3193-1

Source
https://storage.googleapis.com/debian-osv/dla-osv/DLA-3193-1.json
Aliases
Published
2022-11-17T00:00:00Z
Modified
2022-11-17T12:33:51.358757Z
Details

It was discovered that joblib did not properly sanitize arguments to pre_dispatch, allowing arbitrary code execution.

For Debian 10 buster, this problem has been fixed in version 0.13.0-2+deb10u1.

We recommend that you upgrade your joblib packages.

For the detailed security status of joblib please refer to its security tracker page at: https://security-tracker.debian.org/tracker/joblib

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS

References

Affected packages

Debian:10 / joblib

joblib

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
0.13.0-2+deb10u1

Affected versions

0.*

0.13.0-2