DSA-5232-1

Source
https://storage.googleapis.com/debian-osv/dsa-osv/DSA-5232-1.json
Aliases
  • CVE-2022-3008
Published
2022-09-21T00:00:00Z
Modified
2022-09-21T18:26:37.071910Z
Details

It was discovered that the wordexp() function of tinygltf, a library to load/save glTF (GL Transmission Format) files was susceptible to command execution when processing untrusted files.

For the stable distribution (bullseye), this problem has been fixed in version 2.5.0+dfsg-3+deb11u1.

We recommend that you upgrade your tinygltf packages.

For the detailed security status of tinygltf please refer to its security tracker page at: \ https://security-tracker.debian.org/tracker/tinygltf

References

Affected packages

Debian:11 / tinygltf

tinygltf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.5.0+dfsg-3+deb11u1

Affected versions

2.*

2.5.0+dfsg-3