GHSA-22w9-j288-8p9w

Suggest an improvement
Source
https://github.com/advisories/GHSA-22w9-j288-8p9w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-22w9-j288-8p9w/GHSA-22w9-j288-8p9w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-22w9-j288-8p9w
Aliases
  • CVE-2013-6419
Published
2022-05-17T04:50:15Z
Modified
2024-05-19T02:24:38.643119Z
Summary
OpenStack Nova Router metadata queries are not restricted by tenant
Details

Interaction error in OpenStack Nova and Neutron before Havana 2013.2.1 and icehouse-1 does not validate the instance ID of the tenant making a request, which allows remote tenants to obtain sensitive metadata by spoofing the device ID that is bound to a port, which is not properly handled by (1) api/metadata/handler.py in Nova and (2) the neutron-metadata-agent (agent/metadata/agent.py) in Neutron.

References

Affected packages

PyPI / nova

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
12.0.0a0