GHSA-22xp-7rcx-xp34

Suggest an improvement
Source
https://github.com/advisories/GHSA-22xp-7rcx-xp34
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-22xp-7rcx-xp34/GHSA-22xp-7rcx-xp34.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-22xp-7rcx-xp34
Aliases
Published
2022-05-13T01:15:08Z
Modified
2024-02-16T08:06:48.786102Z
Severity
  • 4.2 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Jenkins Slack Notification Plugin missing permission check
Details

Jenkins Slack Notification Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability.

This form validation method now requires POST requests and Overall/Administer (for global configuration) or Item/Configure permissions (for job configuration).

References

Affected packages

Maven / org.jenkins-ci.plugins:slack

Package

Name
org.jenkins-ci.plugins:slack
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/slack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.20

Affected versions

1.*

1.0
1.2
1.7
1.8
1.8.1

2.*

2.0
2.0.1
2.1
2.2
2.3
2.4
2.6
2.7
2.8
2.9
2.10
2.11
2.12
2.13
2.14
2.15
2.16
2.17
2.18
2.19

Database specific

{
    "last_known_affected_version_range": "<= 2.19"
}