GHSA-23c2-gwp5-pxw9

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-23c2-gwp5-pxw9/GHSA-23c2-gwp5-pxw9.json
Aliases
  • CVE-2023-22799
Published
2023-01-18T18:13:19Z
Modified
2023-09-18T20:45:53.416637Z
Details

There is a ReDoS based DoS vulnerability in the GlobalID gem. This vulnerability has been assigned the CVE identifier CVE-2023-22799.

Versions Affected: >= 0.2.1 Not affected: NOTAFFECTED Fixed Versions: 1.0.1 Impact

There is a possible DoS vulnerability in the model name parsing section of the GlobalID gem. Carefully crafted input can cause the regular expression engine to take an unexpected amount of time. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases

The FIXED releases are available at the normal locations. Workarounds

There are no feasible workarounds for this issue. Patches

To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.

1-0-model-name-redos.patch - Patch for 1.0 series
References

Affected packages

RubyGems / globalid

Source Details

Package Name
globalid

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0.2.1
Fixed
1.0.1

Affected versions

0.*

0.2.1
0.2.2
0.2.3
0.3.0
0.3.1
0.3.2
0.3.3
0.3.4
0.3.5
0.3.6
0.3.7
0.4.0
0.4.1
0.4.2
0.5.1
0.5.2
0.6.0

1.*

1.0.0

Ecosystem specific

{
    "affected_functions": [
        ""
    ]
}