GHSA-24w5-w6fw-qqx7

Suggest an improvement
Source
https://github.com/advisories/GHSA-24w5-w6fw-qqx7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-24w5-w6fw-qqx7/GHSA-24w5-w6fw-qqx7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-24w5-w6fw-qqx7
Aliases
Published
2022-05-24T16:59:38Z
Modified
2024-02-16T08:07:14.971395Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins Global Post Script Plugin missing permission check
Details

Jenkins Global Post Script Plugin does not perform permission checks on a method implementing form validation. This allows users with Overall/Read permission to list the files contained in $JENKINS_HOME/global-post-script that can be used by the plugin.

References

Affected packages

Maven / org.jenkins-ci.plugins:global-post-script

Package

Name
org.jenkins-ci.plugins:global-post-script
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/global-post-script

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.1.4

Affected versions

1.*

1.0.6
1.0.7
1.0.8
1.0.9
1.0.10
1.0.12
1.1.0
1.1.1
1.1.1.1
1.1.2
1.1.3
1.1.4