GHSA-25gv-wg6f-6frp

Suggest an improvement
Source
https://github.com/advisories/GHSA-25gv-wg6f-6frp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-25gv-wg6f-6frp/GHSA-25gv-wg6f-6frp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-25gv-wg6f-6frp
Aliases
  • CVE-2022-40043
Published
2022-09-27T00:00:20Z
Modified
2024-02-16T08:11:01.025879Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Centreon SQL Injection vulnerability via esc_name parameter
Details

Centreon v20.10.18 was discovered to contain a SQL injection vulnerability via the esc_name (Escalation Name) parameter at Configuration/Notifications/Escalations. Versions 21.04.16, 21.10.8, and 22.04.2 contain patches.

References

Affected packages

Packagist / centreon/centreon

Package

Name
centreon/centreon
Purl
pkg:composer/centreon/centreon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
21.04.16

Affected versions

2.*

2.7.3
2.99.1
2.99.2
2.99.3
2.99.4
2.99.5

18.*

18.10.6
18.10.7
18.10.8
18.10.9
18.10.10
18.10.11
18.10.12

19.*

19.04.2
19.04.3
19.04.4
19.04.5
19.04.6
19.04.7
19.04.8
19.04.9
19.04.10
19.04.11
19.04.12
19.04.13
19.04.15
19.04.16
19.04.17
19.04.18
19.04.19
19.04.20
19.10.0-beta.1
19.10.0-beta.2
19.10.0-beta.3
19.10.0-rc.1
19.10.0
19.10.1
19.10.2
19.10.3
19.10.4
19.10.5
19.10.6
19.10.7
19.10.8
19.10.9
19.10.10
19.10.12
19.10.13
19.10.14
19.10.15
19.10.16
19.10.17
19.10.18
19.10.19
19.10.20
19.10.21
19.10.22
19.10.23

20.*

20.04.0-beta.1
20.04.0-rc.1
20.04.0-rc.2
20.04.0-rc.3
20.04.0
20.04.2
20.04.3
20.04.4
20.04.6
20.04.7
20.04.8
20.04.9
20.04.10
20.04.11
20.04.12
20.04.13
20.04.14
20.04.15
20.04.16
20.04.17
20.04.18
20.04.19
20.04.20
20.10.0-beta.1
20.10.0
20.10.1
20.10.2
20.10.3
20.10.4
20.10.5
20.10.6
20.10.7
20.10.8
20.10.9
20.10.10
20.10.11
20.10.12
20.10.13
20.10.14
20.10.15
20.10.16
20.10.17
20.10.18

21.*

21.04.0
21.04.1
21.04.2
21.04.3
21.04.4
21.04.5
21.04.6
21.04.7
21.04.8
21.04.9
21.04.10
21.04.11
21.04.12
21.04.13
21.04.14
21.04.15

Packagist / centreon/centreon

Package

Name
centreon/centreon
Purl
pkg:composer/centreon/centreon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
21.10.0
Fixed
21.10.8

Affected versions

21.*

21.10.0
21.10.1
21.10.2
21.10.3
21.10.4
21.10.5
21.10.6
21.10.7

Packagist / centreon/centreon

Package

Name
centreon/centreon
Purl
pkg:composer/centreon/centreon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
22.0.0
Fixed
22.04.2

Affected versions

22.*

22.04.0-beta.1
22.04.0-beta.2
22.04.0
22.04.1

Database specific

{
    "last_known_affected_version_range": "< 22.04.1"
}