GHSA-264w-xrr7-6qqg

Suggest an improvement
Source
https://github.com/advisories/GHSA-264w-xrr7-6qqg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-264w-xrr7-6qqg/GHSA-264w-xrr7-6qqg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-264w-xrr7-6qqg
Aliases
Published
2022-05-24T17:12:40Z
Modified
2024-02-16T08:19:35.691898Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
RCE vulnerability in Jenkins OpenShift Pipeline Plugin
Details

OpenShift Pipeline Plugin 1.0.56 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to OpenShift Pipeline Plugin’s build step. OpenShift Pipeline Plugin 1.0.57 configures its YAML parser to only instantiate safe types.

References

Affected packages

Maven / com.openshift.jenkins:openshift-pipeline

Package

Name
com.openshift.jenkins:openshift-pipeline
View open source insights on deps.dev
Purl
pkg:maven/com.openshift.jenkins/openshift-pipeline

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.57

Affected versions

1.*

1.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.0.9
1.0.10
1.0.11
1.0.12
1.0.13
1.0.14
1.0.15
1.0.16
1.0.17
1.0.18
1.0.19
1.0.20
1.0.21
1.0.22
1.0.23
1.0.24
1.0.25
1.0.26
1.0.27
1.0.28
1.0.29
1.0.30
1.0.31
1.0.32
1.0.33
1.0.34
1.0.35
1.0.36
1.0.37
1.0.38
1.0.39
1.0.40
1.0.41
1.0.42
1.0.43
1.0.44
1.0.45
1.0.46
1.0.47
1.0.48
1.0.49
1.0.50
1.0.51
1.0.52
1.0.53
1.0.54
1.0.55
1.0.56

Database specific

{
    "last_known_affected_version_range": "<= 1.0.56"
}