GHSA-273c-fjw8-v2w8

Suggest an improvement
Source
https://github.com/advisories/GHSA-273c-fjw8-v2w8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-273c-fjw8-v2w8/GHSA-273c-fjw8-v2w8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-273c-fjw8-v2w8
Aliases
  • CVE-2022-34803
Published
2022-07-01T00:01:08Z
Modified
2024-02-16T08:24:57.981575Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins OpsGenie Plugin Plaintext Storage of a Password vulnerability
Details

Jenkins OpsGenie Plugin 1.9 and earlier stores API keys unencrypted in its global configuration file com.opsgenie.integration.jenkins.OpsGenieNotifier.xml and in job config.xml files on the Jenkins controller as part of its configuration.

Additionally, they are transmitted in plain text as part of the respective configuration forms.

These API keys can be viewed by users with Item/Extended Read permission (job config.xml only) or access to the Jenkins controller file system (both).

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:opsgenie

Package

Name
org.jenkins-ci.plugins:opsgenie
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/opsgenie

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.9

Affected versions

1.*

1.2
1.5
1.8
1.9