GHSA-2jgw-28qh-6mg8

Suggest an improvement
Source
https://github.com/advisories/GHSA-2jgw-28qh-6mg8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/04/GHSA-2jgw-28qh-6mg8/GHSA-2jgw-28qh-6mg8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-2jgw-28qh-6mg8
Aliases
  • CVE-2023-30520
Published
2023-04-12T18:30:36Z
Modified
2023-11-08T04:12:23.815298Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Jenkins Quay.io trigger Plugin Cross-site Scripting vulnerability
Details

Jenkins Quay.io trigger Plugin 0.1 and earlier does not limit URL schemes for repository homepage URLs submitted via Quay.io trigger webhooks. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to submit crafted Quay.io trigger webhook payloads.

References

Affected packages

Maven / org.jenkins-ci.plugins:quayio-trigger

Package

Name
org.jenkins-ci.plugins:quayio-trigger
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/quayio-trigger

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
0.1

Affected versions

0.*

0.1