GHSA-2mm9-c2fx-c7m4

Suggest an improvement
Source
https://github.com/advisories/GHSA-2mm9-c2fx-c7m4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/03/GHSA-2mm9-c2fx-c7m4/GHSA-2mm9-c2fx-c7m4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-2mm9-c2fx-c7m4
Aliases
  • CVE-2021-23342
  • SNYK-JAVA-ORGWEBJARSNPM-1076593
  • SNYK-JS-DOCSIFY-1066017
Published
2021-03-01T19:44:27Z
Modified
2023-11-08T04:05:04.327681Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Docsify XSS Vulnerability
Details

This affects the package docsify before 4.12.0. It is possible to bypass the remediation done by CVE-2020-7680 and execute malicious JavaScript through the following methods 1) When parsing HTML from remote URLs, the HTML code on the main page is sanitized, but this sanitization is not taking place in the sidebar. 2) The isURL external check can be bypassed by inserting more //// characters

References

Affected packages

npm / docsify

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.12.0