GHSA-2pcj-76hj-xqhm

Suggest an improvement
Source
https://github.com/advisories/GHSA-2pcj-76hj-xqhm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-2pcj-76hj-xqhm/GHSA-2pcj-76hj-xqhm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-2pcj-76hj-xqhm
Aliases
Published
2022-05-17T02:55:21Z
Modified
2024-04-24T18:11:36.185140Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
CodeIgniter arbitrary code execution
Details

system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.

References

Affected packages

Packagist / codeigniter4/framework

Package

Name
codeigniter4/framework
Purl
pkg:composer/codeigniter4/framework

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.3