GHSA-2wxv-3g4v-p76p

Suggest an improvement
Source
https://github.com/advisories/GHSA-2wxv-3g4v-p76p
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-2wxv-3g4v-p76p/GHSA-2wxv-3g4v-p76p.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-2wxv-3g4v-p76p
Aliases
Published
2022-05-01T07:08:17Z
Modified
2023-11-08T03:56:46.847334Z
Summary
phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence
Details

Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

References

Affected packages

Packagist / phpsysinfo/phpsysinfo

Package

Name
phpsysinfo/phpsysinfo
Purl
pkg:composer/phpsysinfo/phpsysinfo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
3.2.5

Affected versions

v3.*

v3.1.13
v3.1.14
v3.1.15
v3.1.16
v3.1.17
v3.2.0
v3.2.1
v3.2.2
v3.2.3
v3.2.4