GHSA-32gr-x76g-267w

Suggest an improvement
Source
https://github.com/advisories/GHSA-32gr-x76g-267w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/02/GHSA-32gr-x76g-267w/GHSA-32gr-x76g-267w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-32gr-x76g-267w
Aliases
  • CVE-2015-10077
Published
2023-02-10T15:30:28Z
Modified
2023-11-08T03:57:49.394406Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
SQL injection in webbuilders-group silverstripe-kapost-bridge
Details

A vulnerability was found in webbuilders-group silverstripe-kapost-bridge 0.3.3. It has been declared as critical. Affected by this vulnerability is the function index/getPreview of the file code/control/KapostService.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 0.4.0 is able to address this issue. The name of the patch is 2e14b0fd0ea35034f90890f364b130fb4645ff35. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220471.

References

Affected packages

Packagist / webbuilders-group/silverstripe-kapost-bridge

Package

Name
webbuilders-group/silverstripe-kapost-bridge
Purl
pkg:composer/webbuilders-group/silverstripe-kapost-bridge

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4.0

Affected versions

0.*

0.1.0
0.1.1
0.1.2
0.1.3
0.1.4
0.1.5
0.1.6
0.1.7
0.2.0
0.3.0
0.3.1
0.3.2
0.3.3