GHSA-3374-7h99-xr85

Suggest an improvement
Source
https://github.com/advisories/GHSA-3374-7h99-xr85
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/10/GHSA-3374-7h99-xr85/GHSA-3374-7h99-xr85.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3374-7h99-xr85
Aliases
Published
2021-10-25T19:43:05Z
Modified
2023-11-08T04:03:03.711762Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site scripting in forkcms
Details

Fork CMS Content Management System v5.8.0 was discovered to contain a cross-site scripting (XSS) vulnerability in the Displayname field when using the Add, Edit or `Register' functions. This vulnerability allows attackers to execute arbitrary web scripts or HTML.

References

Affected packages

Packagist / forkcms/forkcms

Package

Name
forkcms/forkcms
Purl
pkg:composer/forkcms/forkcms

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.8.1

Affected versions

3.*

3.5.0
3.5.1
3.6.0
3.6.1
3.6.2
3.6.3
3.6.4
3.6.5
3.6.6
3.7
3.7.1
3.7.2
3.7.3
3.8.0
3.8.1
3.8.2
3.8.3
3.8.4
3.8.5
3.8.6
3.8.7
3.9.0
3.9.1
3.9.2
3.9.3
3.9.4
3.9.5
3.9.6

4.*

4.0.0
4.0.1
4.0.2
4.0.3
4.0.4
4.0.5
4.0.6
4.1.0
4.1.1
4.1.2
4.2.0
4.2.1
4.2.2
4.2.3
4.2.4
4.3.0
4.3.1
4.4.0
4.4.1
4.5.0
4.5.1
4.5.2
4.5.3
4.5.4
4.5.5

5.*

5.0.0
5.0.1
5.0.2
5.0.3
5.0.4
5.0.5
5.0.6
5.0.7
5.1.0
5.2.0
5.2.1
5.2.2
5.2.3
5.3.0
5.3.1
5.4.0
5.4.1
5.5.0
5.5.1
5.5.2
5.6.0
5.6.1
5.6.2
5.7.0
5.7.1
5.8.0