GHSA-33gc-6cw9-w3g4

Suggest an improvement
Source
https://github.com/advisories/GHSA-33gc-6cw9-w3g4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/12/GHSA-33gc-6cw9-w3g4/GHSA-33gc-6cw9-w3g4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-33gc-6cw9-w3g4
Aliases
Published
2021-12-10T20:23:19Z
Modified
2024-02-16T08:01:25.862288Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Deserialization of Untrusted Data in topthink/framework
Details

ThinkPHP v6.0.8 was discovered to contain a deserialization vulnerability via the component vendor\league\flysystem-cached-adapter\src\Storage\Adapter.php.

References

Affected packages

Packagist / topthink/framework

Package

Name
topthink/framework
Purl
pkg:composer/topthink/framework

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.9

Affected versions

5.*

5.0-rc1
5.0-rc2
5.0-rc3
5.0-rc4
5.0

v5.*

v5.0.1
v5.0.2
v5.0.3
v5.0.4
v5.0.5
v5.0.6
v5.0.7
v5.0.8
v5.0.9
v5.0.10
v5.0.11
v5.0.12
v5.0.13
v5.0.14
v5.0.15
v5.0.16
v5.0.17
v5.0.18
v5.0.19
v5.0.20
v5.0.21
v5.0.22
v5.0.23
v5.0.24
v5.0.25
v5.1-beta.1
v5.1-rc.1
v5.1-rc.2
v5.1-rc.3
v5.1.0
v5.1.1
v5.1.2
v5.1.3
v5.1.4
v5.1.5
v5.1.6
v5.1.7
v5.1.8
v5.1.9
v5.1.10
v5.1.11
v5.1.12
v5.1.13
v5.1.14
v5.1.15
v5.1.16
v5.1.17
v5.1.18
v5.1.19
v5.1.20
v5.1.21
v5.1.22
v5.1.23
v5.1.24
v5.1.25
v5.1.26
v5.1.27
v5.1.28
v5.1.29
v5.1.30
v5.1.31
v5.1.32
v5.1.33
v5.1.34
v5.1.35
v5.1.36
v5.1.37
v5.1.37.1
v5.1.38
v5.1.38.1
v5.1.39
v5.1.40
v5.1.41
v5.1.42
v5.2-beta.2
v5.2-beta.3
v5.2-rc1

v6.*

v6.0.0-rc2
v6.0.0-rc3
v6.0.0-rc4
v6.0.0-rc5
v6.0.0
v6.0.1
v6.0.2
v6.0.3
v6.0.4
v6.0.5
v6.0.6
v6.0.7
v6.0.8