GHSA-347f-rxg8-qgrv

Suggest an improvement
Source
https://github.com/advisories/GHSA-347f-rxg8-qgrv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-347f-rxg8-qgrv/GHSA-347f-rxg8-qgrv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-347f-rxg8-qgrv
Aliases
Published
2023-03-08T12:30:16Z
Modified
2023-11-08T04:11:15.624433Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Easy!Appointments uses hard-coded credentials
Details

Use of Hard-coded Credentials in GitHub repository alextselegidis/easyappointments 1.4.3 and prior. A patch is available and anticipated to be part of version 1.5.0.

References

Affected packages

Packagist / alextselegidis/easyappointments

Package

Name
alextselegidis/easyappointments
Purl
pkg:composer/alextselegidis/easyappointments

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.4.3

Affected versions

1.*

1.1.0-beta.1
1.1.0-beta.2
1.1.0
1.1.1
1.2.0-alpha.1
1.2.0-beta.1
1.2.0
1.2.1
1.3.0-alpha.1
1.3.0-beta.1
1.3.0-beta.2
1.3.0
1.3.1-beta.1
1.3.1
1.3.2-beta.1
1.3.2
1.4.0-beta.1
1.4.0
1.4.1
1.4.2-beta.1
1.4.2
1.4.3-beta.1
1.4.3