GHSA-3487-3j7c-7gwj

Suggest an improvement
Source
https://github.com/advisories/GHSA-3487-3j7c-7gwj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/11/GHSA-3487-3j7c-7gwj/GHSA-3487-3j7c-7gwj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3487-3j7c-7gwj
Aliases
Related
Published
2023-11-27T12:30:55Z
Modified
2024-07-15T22:12:26.683636Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L CVSS Calculator
Summary
Mattermost Uncontrolled Resource Consumption vulnerability
Details

Mattermost fails to limit the log size of server logs allowing an attacker sending specially crafted requests to different endpoints to potentially overflow the log.

References

Affected packages

Go / github.com/mattermost/mattermost/server/v8

Package

Name
github.com/mattermost/mattermost/server/v8
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost/server/v8

Affected ranges

Type
SEMVER
Events
Introduced
9.1.0
Fixed
9.1.1

Go / github.com/mattermost/mattermost/server/v8

Package

Name
github.com/mattermost/mattermost/server/v8
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost/server/v8

Affected ranges

Type
SEMVER
Events
Introduced
9.0.0
Fixed
9.0.2

Go / github.com/mattermost/mattermost/server/v8

Package

Name
github.com/mattermost/mattermost/server/v8
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost/server/v8

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.1.4

Go / github.com/mattermost/mattermost-server/v6

Package

Name
github.com/mattermost/mattermost-server/v6
View open source insights on deps.dev
Purl
pkg:golang/github.com/mattermost/mattermost-server/v6

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.8.13