GHSA-3627-w2qr-5fxr

Suggest an improvement
Source
https://github.com/advisories/GHSA-3627-w2qr-5fxr
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/02/GHSA-3627-w2qr-5fxr/GHSA-3627-w2qr-5fxr.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3627-w2qr-5fxr
Aliases
  • CVE-2016-10576
Published
2019-02-18T23:52:07Z
Modified
2023-11-08T03:58:13.611731Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
fuseki downloads Resources over HTTP
Details

Affected versions of fuseki insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running fuseki.

Recommendation

Update to version 1.0.1 or later.

References

Affected packages

npm / fuseki

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.1