GHSA-3885-8gqc-3wpf

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-3885-8gqc-3wpf/GHSA-3885-8gqc-3wpf.json
Aliases
  • CVE-2022-30184
Published
2022-06-14T21:57:52Z
Modified
2022-06-14T22:17:08.508580Z
Details

Description

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET Core 3.1, NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.

A vulnerability exists in .NET 6.0, .NET Core 3.1, and NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0) where a nuget.org api key could leak due to an incorrect comparison with a server url.

Affected software

NuGet & NuGet Packages

  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.2.0 version or earlier.
  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.0.1 version or earlier.
  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 5.11.1 version or earlier.
  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 5.9.1 version or earlier.
  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 5.7.1 version or earlier.
  • Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 4.9.4 version or earlier.

.NET SDK(s)

  • Any .NET 6.0 application running on .NET 6.0.5 or earlier.
  • Any .NET 3.1 application running on .NET Core 3.1.25 or earlier.

Patches

  • If you're using NuGet.exe 6.2.0 or lower, you should download and install 6.2.1 from https://dist.nuget.org/win-x86-commandline/v6.2.1/nuget.exe.

  • If you're using NuGet.exe 6.0.1 or lower, you should download and install 6.0.2 from https://dist.nuget.org/win-x86-commandline/v6.0.2/nuget.exe.

  • If you're using NuGet.exe 5.11.1 or lower, you should download and install 5.11.2 from https://dist.nuget.org/win-x86-commandline/v5.11.2/nuget.exe.

  • If you're using NuGet.exe 5.9.1 or lower, you should download and install 5.9.2 from https://dist.nuget.org/win-x86-commandline/v5.9.2/nuget.exe.

  • If you're using NuGet.exe 5.7.1 or lower, you should download and install 5.7.2 from https://dist.nuget.org/win-x86-commandline/v4.7.2/nuget.exe.

  • If you're using NuGet.exe 4.9.4 or lower, you should download and install 4.9.5 from https://dist.nuget.org/win-x86-commandline/v4.9.5/nuget.exe.

  • If you're using .NET Core 6.0, you should download and install Runtime 6.0.6 or SDK 6.0.106 (for Visual Studio 2022 v17.0) or SDK 6.0.301 (for Visual Studio 2022 v17.2) from https://dotnet.microsoft.com/download/dotnet-core/6.0.

  • If you're using .NET Core 3.1, you should download and install Runtime 3.1.26 or SDK 3.1.420 (for Visual Studio 2019 v16.9 or Visual Studio 2011 16.11 or Visual Studio 2022 17.0 or Visual Studio 2022 17.1 ) from https://dotnet.microsoft.com/download/dotnet-core/3.1

.NET 6.0 and .NET Core 3.1 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.

Other Details

Announcement for this issue can be found at https://github.com/NuGet/Announcements/issues/62

MSRC details for this can be found at https://msrc.microsoft.com/update-guide/en-US/vulnerability/CVE-2022-30184

References

Affected packages

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5.0
Fixed
4.9.5

Affected versions

3.*

3.5.0

4.*

4.0.0
4.0.0-rc-2048
4.0.0-rc2
4.0.0-rc3
4.0.0-rtm-2265
4.0.0-rtm-2283
4.1.0
4.2.0
4.3.0
4.3.0-beta1-2418
4.3.0-preview3-4168
4.3.0-preview4
4.3.0-rtm-4324
4.3.1
4.4.0
4.4.0-preview3-4475
4.5.0
4.5.0-rtm-4651
4.6.0
4.6.0-rtm-4791
4.6.0-rtm-4825
4.6.0-rtm-4918
4.6.1
4.6.2
4.6.3
4.6.4
4.7.0-preview1-4986

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5.0
Fixed
4.9.5

Affected versions

3.*

3.5.0

4.*

4.0.0-rc2
4.1.0
4.3.0
4.3.0-preview3-4168
4.3.1
4.4.1
4.4.1-svc
4.5.0
4.5.1
4.6.2
4.6.3
4.6.4
4.7.1
4.7.2
4.7.3
4.8.2
4.9.2
4.9.3
4.9.4

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5.0
Fixed
4.9.5

Affected versions

3.*

3.5.0

4.*

4.0.0-rc-2048
4.0.0-rc2
4.0.0-rc3
4.0.0-rtm-2265
4.0.0-rtm-2283
4.1.0
4.2.0
4.3.0
4.3.0-beta1-2418
4.3.0-preview3-4168
4.3.0-preview4
4.3.0-rtm-4324
4.3.1
4.4.0
4.4.0-preview3-4475
4.5.0
4.5.0-rtm-4651
4.6.0
4.6.0-rtm-4791
4.6.0-rtm-4825
4.6.0-rtm-4918
4.6.1
4.6.2
4.6.3
4.6.4
4.7.0-preview1-4986

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.0.0
Fixed
5.2.1

Affected versions

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.3.0
Fixed
5.7.2

Affected versions

5.*

5.7.1

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.8.0
Fixed
5.9.2

Affected versions

5.*

5.9.0
5.9.1

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.10.0
Fixed
5.11.2

Affected versions

5.*

5.10.0
5.11.0

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0.0
Fixed
6.0.2

Affected versions

6.*

6.0.0

NuGet / NuGet.Commands

NuGet.Commands

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.1.0
Fixed
6.2.1

Affected versions

6.*

6.1.0
6.2.0

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.0.0
Fixed
5.2.1

Affected versions

5.*

5.0.2
5.1.0
5.2.0

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.3.0
Fixed
5.7.2

Affected versions

5.*

5.3.0
5.3.1
5.4.0
5.5.1
5.6.0
5.7.0
5.7.1

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.8.0
Fixed
5.9.2

Affected versions

5.*

5.8.0
5.8.1
5.9.1

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.10.0
Fixed
5.11.2

Affected versions

5.*

5.10.0
5.11.0

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0.0
Fixed
6.0.2

Affected versions

6.*

6.0.0

NuGet / NuGet.CommandLine

NuGet.CommandLine

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.1.0
Fixed
6.2.1

Affected versions

6.*

6.1.0
6.2.0

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.0.0
Fixed
5.2.1

Affected versions

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.3.0
Fixed
5.7.2

Affected versions

5.*

5.7.1

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.8.0
Fixed
5.9.2

Affected versions

5.*

5.9.0
5.9.1

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.10.0
Fixed
5.11.2

Affected versions

5.*

5.10.0
5.11.0

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0.0
Fixed
6.0.2

Affected versions

6.*

6.0.0

NuGet / NuGet.CommandLine.XPlat

NuGet.CommandLine.XPlat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.1.0
Fixed
6.2.1

Affected versions

6.*

6.1.0
6.2.0