GHSA-38m2-vr6g-8c94

Suggest an improvement
Source
https://github.com/advisories/GHSA-38m2-vr6g-8c94
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-38m2-vr6g-8c94/GHSA-38m2-vr6g-8c94.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-38m2-vr6g-8c94
Aliases
Published
2023-01-09T12:30:18Z
Modified
2023-11-08T04:10:57.774496Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Apache Sling App CMS vulnerable to reflected Cross-site Scripting
Details

An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Sling App CMS version 1.1.2 and prior may allow an authenticated remote attacker to perform a reflected cross-site scripting (XSS) attack in the site group feature. Upgrade to Apache Sling App CMS >= 1.1.4

References

Affected packages

Maven / org.apache.sling:org.apache.sling.cms

Package

Name
org.apache.sling:org.apache.sling.cms
View open source insights on deps.dev
Purl
pkg:maven/org.apache.sling/org.apache.sling.cms

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.4

Affected versions

0.*

0.9.0
0.10.0
0.11.0
0.11.2
0.12.0
0.14.0
0.16.0
0.16.2

1.*

1.0.2
1.0.4
1.1.0
1.1.2