GHSA-3f48-9j7q-q2gv

Suggest an improvement
Source
https://github.com/advisories/GHSA-3f48-9j7q-q2gv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/10/GHSA-3f48-9j7q-q2gv/GHSA-3f48-9j7q-q2gv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3f48-9j7q-q2gv
Aliases
  • CVE-2023-4570
Published
2023-10-05T20:56:37Z
Modified
2024-02-16T08:14:13.522824Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
NI MeasurementLink Python Services Improper Access Restriction vulnerability
Details

Impact

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Patches

Upgrade all Python measurement plug-ins to use ni-measurementlink-service version 1.1.1 or later.

References

Visit ni.com/info and enter the info code cve-2023-4570 for more information.

References

Affected packages

PyPI / ni-measurementlink-service

Package

Name
ni-measurementlink-service
View open source insights on deps.dev
Purl
pkg:pypi/ni-measurementlink-service

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.1

Affected versions

0.*

0.12.0
0.12.1
0.12.2

1.*

1.0.0
1.0.1
1.1.0.dev0
1.1.0.dev1
1.1.0.dev2
1.1.0

PyPI / ni-measurementlink-service

Package

Name
ni-measurementlink-service
View open source insights on deps.dev
Purl
pkg:pypi/ni-measurementlink-service

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.2.0.dev0
Fixed
1.2.0

Affected versions

1.*

1.2.0.dev0
1.2.0.dev1
1.2.0.dev2
1.2.0.dev3