GHSA-3gx9-37ww-9qw6

Suggest an improvement
Source
https://github.com/advisories/GHSA-3gx9-37ww-9qw6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/03/GHSA-3gx9-37ww-9qw6/GHSA-3gx9-37ww-9qw6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3gx9-37ww-9qw6
Aliases
Published
2022-03-04T00:00:15Z
Modified
2024-02-16T08:19:02.311663Z
Severity
  • 10.0 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS Calculator
Summary
Spring Cloud Gateway vulnerable to Code Injection when Gateway Actuator endpoint enabled, exposed, unsecured
Details

In Spring Cloud Gateway versions prior to 3.1.1+ and 3.0.7+ , applications are vulnerable to a code injection attack when the Gateway Actuator endpoint is enabled, exposed, and unsecured. A remote attacker could make a maliciously crafted request resulting in arbitrary remote execution on the remote host.

References

Affected packages

Maven / org.springframework.cloud:spring-cloud-gateway

Package

Name
org.springframework.cloud:spring-cloud-gateway
View open source insights on deps.dev
Purl
pkg:maven/org.springframework.cloud/spring-cloud-gateway

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.7

Affected versions

1.*

1.0.0.RELEASE
1.0.1.RELEASE
1.0.2.RELEASE
1.0.3.RELEASE

2.*

2.0.0.RELEASE
2.0.1.RELEASE
2.0.2.RELEASE
2.0.3.RELEASE
2.0.4.RELEASE
2.1.0.RELEASE
2.1.1.RELEASE
2.1.2.RELEASE
2.1.3.RELEASE
2.1.4.RELEASE
2.1.5.RELEASE
2.2.0.RELEASE
2.2.1.RELEASE
2.2.2.RELEASE
2.2.3.RELEASE
2.2.4.RELEASE
2.2.5.RELEASE
2.2.6.RELEASE
2.2.7.RELEASE
2.2.8.RELEASE
2.2.9.RELEASE
2.2.10.RELEASE

3.*

3.0.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6

Maven / org.springframework.cloud:spring-cloud-gateway

Package

Name
org.springframework.cloud:spring-cloud-gateway
View open source insights on deps.dev
Purl
pkg:maven/org.springframework.cloud/spring-cloud-gateway

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.1.0
Fixed
3.1.1

Affected versions

3.*

3.1.0