GHSA-3mcp-9wr4-cjqf

Suggest an improvement
Source
https://github.com/advisories/GHSA-3mcp-9wr4-cjqf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2020/02/GHSA-3mcp-9wr4-cjqf/GHSA-3mcp-9wr4-cjqf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3mcp-9wr4-cjqf
Aliases
Published
2020-02-24T17:27:27Z
Modified
2024-06-05T16:45:45.647294Z
Severity
  • 7.9 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L CVSS Calculator
Summary
Remote Code Execution (RCE) vulnerability in dropwizard-validation
Details

Dropwizard-Validation before 1.3.19, and 2.0.2 may allow arbitrary code execution on the host system, with the privileges of the Dropwizard service account, by injecting arbitrary Java Expression Language expressions when using the self-validating feature.

Summary

A server-side template injection was identified in the self-validating (@SelfValidating) feature of dropwizard-validation enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability.

If you're using a self-validating bean (via @SelfValidating), an upgrade to Dropwizard 1.3.19 or 2.0.2 is strongly recommended.

Impact

This issue may allow Remote Code Execution (RCE), allowing to run arbitrary code on the host system (with the privileges of the Dropwizard service account privileges) by injecting arbitrary Java Expression Language (EL) expressions when using the self-validating feature (@SelfValidating, @SelfValidation) in dropwizard-validation.

Patches

The issue has been fixed in dropwizard-validation 1.3.19 and 2.0.2. We strongly recommend upgrading to one of these versions.

Workarounds

If you are not able to upgrade to one of the aforementioned versions of dropwizard-validation but still want to use the @SelfValidating feature, make sure to properly sanitize any message you're adding to the ViolationCollector in the method annotated with @SelfValidation.

Example:

@SelfValidation
public void validateFullName(ViolationCollector col) {
    if (fullName.contains("_")) {
        // Sanitize fullName variable by escaping relevant characters such as "$"
        col.addViolation("Full name contains invalid characters:  " + sanitizeJavaEl(fullName));
    }
}

See also: https://github.com/dropwizard/dropwizard/blob/v2.0.2/dropwizard-validation/src/main/java/io/dropwizard/validation/selfvalidating/ViolationCollector.java#L84-L98

References

  • https://github.com/dropwizard/dropwizard/pull/3157
  • https://github.com/dropwizard/dropwizard/pull/3160
  • https://docs.oracle.com/javaee/7/tutorial/jsf-el.htm
  • https://docs.jboss.org/hibernate/validator/6.1/reference/en-US/html_single/#section-interpolation-with-message-expressions
  • https://beanvalidation.org/2.0/spec/#validationapi-message-defaultmessageinterpolation

For more information

If you have any questions or comments about this advisory: * Open an issue in dropwizard/dropwizard * Start a discussion on the dropwizard-dev mailing list

Security contact

If you want to responsibly disclose a security issue in Dropwizard or one of its official modules, please contact us via the published channels in our security policy:

https://github.com/dropwizard/dropwizard/security/policy#reporting-a-vulnerability

References

Affected packages

Maven / io.dropwizard:dropwizard-validation

Package

Name
io.dropwizard:dropwizard-validation
View open source insights on deps.dev
Purl
pkg:maven/io.dropwizard/dropwizard-validation

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.3.0
Fixed
1.3.19

Affected versions

1.*

1.3.0
1.3.1
1.3.2
1.3.3
1.3.4
1.3.5
1.3.6
1.3.7
1.3.8
1.3.9
1.3.10
1.3.11
1.3.12
1.3.13
1.3.14
1.3.15
1.3.16
1.3.17
1.3.18

Maven / io.dropwizard:dropwizard-validation

Package

Name
io.dropwizard:dropwizard-validation
View open source insights on deps.dev
Purl
pkg:maven/io.dropwizard/dropwizard-validation

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0
Fixed
2.0.2

Affected versions

2.*

2.0.0
2.0.1