GHSA-3wqf-4x89-9g79

Suggest an improvement
Source
https://github.com/advisories/GHSA-3wqf-4x89-9g79
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-3wqf-4x89-9g79/GHSA-3wqf-4x89-9g79.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3wqf-4x89-9g79
Aliases
Published
2022-05-13T01:07:54Z
Modified
2024-03-09T05:17:17.300224Z
Severity
  • CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Summary
Bootstrap vulnerable to Cross-Site Scripting (XSS)
Details

In Bootstrap starting in version 2.3.0 and prior to 3.4.0, as well as 4.x before 4.1.2, XSS is possible in the collapse data-parent attribute.

References

Affected packages

npm / bootstrap

Package

Affected ranges

Type
SEMVER
Events
Introduced
4.0.0
Fixed
4.1.2

RubyGems / bootstrap

Package

Name
bootstrap
Purl
pkg:gem/bootstrap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.0.0
Fixed
4.1.2

Affected versions

4.*

4.0.0
4.1.0
4.1.1

npm / bootstrap

Package

Affected ranges

Type
SEMVER
Events
Introduced
2.3.0
Fixed
3.4.0

RubyGems / bootstrap

Package

Name
bootstrap
Purl
pkg:gem/bootstrap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.3.0
Fixed
3.4.0