GHSA-3xh5-5v5v-mfgm

Suggest an improvement
Source
https://github.com/advisories/GHSA-3xh5-5v5v-mfgm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-3xh5-5v5v-mfgm/GHSA-3xh5-5v5v-mfgm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-3xh5-5v5v-mfgm
Aliases
Published
2022-05-24T17:11:48Z
Modified
2024-04-26T23:16:20.249321Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Moodle reflected Cross-site Scripting (XSS)
Details

A vulnerability was found in Moodle 3.7 before 3.7.3, 3.6 before 3.6.7 and 3.5 before 3.5.9, where a reflected XSS possible from some fatal error messages.

References

Affected packages

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.7.0
Fixed
3.7.3

Affected versions

v3.*

v3.7.0
v3.7.1
v3.7.2

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.6.0
Fixed
3.6.7

Affected versions

v3.*

v3.6.0
v3.6.1
v3.6.2
v3.6.3
v3.6.4
v3.6.5
v3.6.6

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5.0
Fixed
3.5.9

Affected versions

v3.*

v3.5.0
v3.5.1
v3.5.2
v3.5.3
v3.5.4
v3.5.5
v3.5.6
v3.5.7
v3.5.8