GHSA-42q4-9xf9-f67x

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-42q4-9xf9-f67x/GHSA-42q4-9xf9-f67x.json
Aliases
  • CVE-2021-41972
Published
2022-05-24T19:20:31Z
Modified
2022-06-21T20:32:32.589149Z
Details

Apache Superset up to and including 1.3.1 allowed for database connections password leak for authenticated users. This information could be accessed in a non-trivial way.

References

Affected packages

PyPI / apache-superset

apache-superset

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
1.3.2

Affected versions

0.*

0.34.0
0.34.1
0.35.1
0.35.2
0.36.0
0.37.0
0.37.1
0.37.2
0.38.0
0.38.1

1.*

1.0.0
1.0.1
1.1.0
1.2.0
1.3.0
1.3.1

Database specific

{
    "last_known_affected_version_range": "<= 1.3.1"
}