GHSA-457r-cqc8-9vj9

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/11/GHSA-457r-cqc8-9vj9/GHSA-457r-cqc8-9vj9.json
Published
2022-11-23T15:39:50Z
Modified
2022-11-23T15:39:50Z
Details

sweetalert2 versions 10.16.10 and up until 11.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 10.0.0 - 10.16.9.

Workaround

Use a version 10.0.0 - 10.16.9 of the package until the maintainer releases a fix.

References

Affected packages

npm / sweetalert2

sweetalert2

Affected ranges

Type
SEMVER
Events
Introduced
10.16.10

Affected versions

Database specific

{
    "last_known_affected_version_range": "< 11.0.0"
}