GHSA-49pj-69vf-c689

Suggest an improvement
Source
https://github.com/advisories/GHSA-49pj-69vf-c689
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/10/GHSA-49pj-69vf-c689/GHSA-49pj-69vf-c689.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-49pj-69vf-c689
Aliases
Published
2019-10-14T21:43:19Z
Modified
2023-11-08T04:01:23.578796Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
netaddr before 1.5.3 and 2.0.4 has Incorrect Default Permissions
Details

The netaddr gem before 1.5.3 and 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.

References

Affected packages

RubyGems / netaddr

Package

Name
netaddr
Purl
pkg:gem/netaddr

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0
Fixed
2.0.4

Affected versions

2.*

2.0.1
2.0.3

RubyGems / netaddr

Package

Name
netaddr
Purl
pkg:gem/netaddr

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.3

Affected versions

1.*

1.0.0
1.1.0
1.2.0
1.3.0
1.4.0
1.5.0
1.5.1