GHSA-4f68-49qq-h392

Suggest an improvement
Source
https://github.com/advisories/GHSA-4f68-49qq-h392
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/05/GHSA-4f68-49qq-h392/GHSA-4f68-49qq-h392.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4f68-49qq-h392
Aliases
Published
2021-05-24T18:12:20Z
Modified
2024-02-16T08:24:55.783264Z
Severity
  • 7.4 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Improper certificate validation in em-imap
Details

em-imap 0.5 and earlier use the library eventmachine in an insecure way that allows an attacker to perform a man-in-the-middle attack against users of the library. The hostname in a TLS server certificate is not verified.

References

Affected packages

RubyGems / em-imap

Package

Name
em-imap
Purl
pkg:gem/em-imap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
0.5

Affected versions

0.*

0.1
0.1.1
0.2
0.2.1
0.2.2
0.3.0
0.4.0
0.4.1
0.5