GHSA-4g29-r7vj-2rpv

Suggest an improvement
Source
https://github.com/advisories/GHSA-4g29-r7vj-2rpv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/10/GHSA-4g29-r7vj-2rpv/GHSA-4g29-r7vj-2rpv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-4g29-r7vj-2rpv
Aliases
Published
2022-10-19T19:00:22Z
Modified
2024-02-16T08:23:40.739656Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins Job Import Plugin allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins
Details

Jenkins Job Import Plugin 3.5 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. An enumeration of credentials IDs in Job Import Plugin 3.6 requires Job Import/Import Jobs permission.

References

Affected packages

Maven / org.jenkins-ci.plugins:job-import-plugin

Package

Name
org.jenkins-ci.plugins:job-import-plugin
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/job-import-plugin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.6

Affected versions

1.*

1.0
1.1
1.2
1.3
1.3.1
1.5
1.6
1.7
1.8

2.*

2.0
2.1

3.*

3.0
3.1
3.2
3.3
3.4
3.5

Database specific

{
    "last_known_affected_version_range": "<= 3.5"
}